Resolve an 'Another version of this product is already installed' error in LogMeIn Hamachi
When the Windows Registry detects inconsistency, you cannot fully uninstall the host software.
Symptom
Another version of this product is already installed. Installation of this version cannot continue.
Cause
This issue is typically due to a corruption or inconsistency in the local database Windows uses to keep track of installed software.
Resolution
- Press the Windows key + R. The Run box is displayed.
- Type regedit and select Ok.
- Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\
- Select each key, until you find one that has Product Name set as RemotelyAnywhere, , or LogMeIn Hamachi in the right pane.
- Delete the selected key.
- Reboot the PC.
- Reinstall the software.
After the installation is complete, you can now uninstall the software using the Windows Control Panel.