HELP FILE

Install the GoToMeeting Mac Outlook Plugin (Decommissioned)

The Mac Schedule was discontinued on Oct. 1, 2019. Thank you for using the plugin. We encourage you to install and use the GoToMeeting Office 365 Outlook Add-In !

System Requirements

  • Mac OS X 10.10 or later
  • Microsoft Outlook 2011 – 2016

Install the GoToMeeting Scheduler

The Mac Schedule was discontinued on Oct. 1, 2019. Thank you for using the plugin. We encourage you to install and use the GoToMeeting Office 365 Outlook Add-In!